64位版x-plane 10 Version 10.20起动问题终于解决,升级与注意事项

困扰了我很长时间的64位版x-plane 10 终于能用了,
原来只要把Mac OS上的语言设置改成英文,然后再把程序更新到最新版,
比如到今天为止的最新版为10.20b11,
起动程序,然后就跟什么事儿也没有发生过一样,64位版就正常地启动了。

升级到最新版以后,主目录下会出现两个可执行文件,比如OS 是windows时你会发现出现X-Plane.exe和X-Plane-32bit.exe,X-Plane.exe是64位版的而X-Plane-32bit.exe是32位版。如果你的机器内存不够大,比如说只有4G,那么使用64位版是没有什么意义的,有X-Plane-32bit.exe这个选择你就可以在比较低配置的机器上享受到最新版的新功能了。
我的建议是你两个程序都试试看,如果64位的比较流畅就用64位的,如果比较慢的话就用32位的,但是如果32位的还是慢的话就没办法了,只好降回到10.10用了。

64位版有什么好处呢?其实也不多,就是没有内存4G的限制,可以加载更精美的地景文件什么的。
别以为升级到64位版以后,x-plane会变快,或者变得更漂亮什么的,其实速度什么的跟以前都一样。


支 持 本 站: 捐赠服务器等运维费用,感谢您的支持!

那么为什么还要升级到64位呢?
因为它可以更有效的使用内存,以往时不时发生的内存不足的问题就不会发生。
另外把大量地景文件读入内存后,
很明显地可以感觉到飞行中以前为了读硬盘而发生的短暂停顿基本没有了,
整个程序的运行变得非常流畅,这一点是我升级以后感到最大的好处。
还有感觉这个版本在抗锯齿(即边缘柔化)方面也有进步,物体的边缘变得比以前更圆滑,失真度要小一些了。

不过升级以后很多机体,工具插件就用不了了,必须需要升级。
如果插件开发者没有保持更新的话那么很不幸,这插件就不会被起动。具体哪些能用哪些用不了这只能靠碰运气了。一般来说看看插件的更新日期,如果是去年11月以后的,估计应该都没问题。但是我很喜欢的这个降落速度显示与评价Landing Speed Plugin现在就用不了了,很是遗憾。好在PythonInterface已经升级完毕,很多使用python开发的插件都能正常使用,比如GMAP FOR X-PLANE (FREE MOVING MAP)Ground Services 地面服务 plugin等没有问题。


因此升级完x-plane以后,你一定首先更新一下 PythonInterface这个著名插件,
这个下载页面里有最新的版本,你一定要下载适合你机器的Python版本的PythonInterface.zip,并安装到plugins目录下。对了,以前的目录PythonInterface要先删除的。
PythonInterface对应的插件都放在PythonScripts目录下面,一般来说不用动它们基本这件插件都能使用。

还有NaturalPoint TrackIR 5 & TrackClip Pro的Mac驱动也需要更新,
你要下载这个64版用的库文件xlinuxtrack9.0.dylib ,然后右键点击以前安装好的
ltr_gui.app文件,点击 "Show package contents"菜单, 选择Contents/Frameworks目录,把老的xlinuxtrack9.0.dylib 删掉,然后把刚刚下载的xlinuxtrack9.0.dylib 拷进来,重新起动x-plane就行了。

如果你想享受一下64位版高清的地景,可以考虑下载这个著名的新西兰的插件
使用方法我写到另一篇blog全新西兰高清地景 New Zealand Pro Scenery里了,敬请参考。

支 持 本 站: 捐赠服务器等运维费用,感谢您的支持!